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Εισαγωγή 

Γενικά για το AuthorWare. 
Το AuthorWare είναι ένα πρόγραμμα της εταιρείας Macromedia για τη 

δημιουργία εφαρμογών πολυμέσων. Ο τρόπος δόμησης ακολουθεί τον τρόπο 
δόμησης ενός λογικού διαγράμματος προγράμματος. Όλα γίνονται με τα εργαλεία 
που έχει και με τα οποία ρυθμίζουμε το πώς θα εμφανίζονται (ή θα εξαφανίζονται) 
στην οθόνη του χρήστη αυτά που θέλουμε εμείς. 

Όταν ξεκινάμε στο αριστερό μέρος της οθόνης υπάρχουν τα εικονίδια των 
σχετικών εργαλείων και εμφανίζεται η περιοχή εργασίας μας (δηλ δόμησης της 
εφαρμογής). Διαλέγουμε το εικονίδιο που θέλουμε και το σέρνουμε στην περιοχή 
εργασίας μας. Μπορούμε έτσι να εμφανίσουμε κάποια πράγματα στην οθόνη του 
χρήστη (είτε αυτά είναι εικόνες είτε κείμενο) και τα οποία θα μένουν εκεί μέχρι να 
δώσουμε εντολή να διαγραφούν είτε με το εργαλείο διαγραφής είτε με την ρύθμισης 
της ιδιότητας του συγκεκριμένου εικονιδίου. 

Το κύριο εικονίδιο είναι το display που εμφανίζει κάποιες πληροφορίες. 
Υπάρχει επίσης το erase και το wait για διαγραφή προηγούμενων display ή για 
αναμονή μέχρι να συμβεί κάτι. Το map για δόμηση της εφαρμογής μας σε επίπεδα, 
το interaction  για να περιμένουμε κάποια ενέργεια του χρήστη και το decision για να 
οδηγήσουμε την εφαρμογή μας σε συγκεκριμένα μονοπάτια. Κάποια κομμάτια 
κώδικα που χρειάζεται να γραφούν γράφονται μέσα από ένα  Calculation. 

Και βέβαια πώς θα μπορούσαμε να έχουμε πολυμέσα χωρίς κίνηση και ήχο! 
Το motion δίνει κίνηση σε αντικείμενα που έχουν ήδη σχεδιαστεί στην οθόνη, το 
Digital Movie που μας επιτρέπει να εισάγουμε κινούμενη εικόνα (σε μορφή βίντεο ή 
ακόμα και σειρά μεταβλητών εικόνων) και το Sound για ήχο και Video για παίξιμο 
αρχείου βίντεο. 

Και μιας και είμαστε στην εποχή του Ιντερνέτ Δεν μπορούσαν να λείπουν και 
τα κουμπιά για πλοήγηση είτε στο δίκτυο είτε στην ίδια μας την εφαρμογή. Το Frame 
σε συνδυασμό με το Navigate μας δίνουν τη λύση. 

Ας ξεκινήσουμε όμως να φτιάξουμε μια εφαρμογή και να τα δούμε όλα αυτά σε 
χρήση. Θα φτιάξουμε μια παρουσίαση για το τι είναι η φωτογραφία και πώς δουλεύει 
μια φωτογραφική μηχανή. Στο τέλος θα παρουσιάσουμε μια ρεαλιστική διαδικασία 
φωτογράφησης. Για το σκοπό αυτό θα χρησιμοποιήσουμε την έκδοση 5 του 
AuthorWare. 
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Τα μαθήματα έχουν χρησιμοποιηθεί για τη διδασκαλία τμήματος του 
μαθήματος “Πολυμέσα” της Β’ τάξης ΤΕΕ (Τομέας πληροφορικής και Δικτύων) στο 
ΤΕΕ Αγίου Στεφάνου κατά το σχολικό έτος 2000 - 2001. Για την ολοκλήρωση κάθε 
μαθήματος χρειάστηκαν (από τους μαθητές, στην τάξη μέσα) περίπου δυο διδακτικές 
ώρες. 

Συμβάσεις γραφής 
Όταν είναι κάτι που πρέπει να πληκτρολογήσετε θα εμφανίζεται με έντονη 

γραφή ενώ όταν πρέπει απλά να το επιλέξετε θα είναι με πλάγια γραφή. Όταν είναι να 
δώσετε κάποια εντολή από το μενού θα εμφανίζεται σε πλάγια γραφή (αλλά με 
γραμματοσειρά Times New Roman) και με τα στάδια των μενού που θα 
χρησιμοποιήσετε (π.χ. “Control -> Restart from Flag"). Αν πρέπει να αναφερθείτε σε 
κάποιο αντικείμενο που έχουμε ονομάσει ή κάποιο αρχείο που θα εισάγετε θα 
χρησιμοποιείται  υπογραμμισμένη γραφή. 

Ο όρος «πατήστε» σημαίνει να βάλουμε το δείκτη του ποντικιού στο 
συγκεκριμένο σημείο και να κάνουμε κλικ με το αριστερό πλήκτρο. 

Αν στα ονόματα αρχείων που δίνονται, δεν βλέπετε τις επεκτάσεις (π.χ. bmp) 
σημαίνει ότι έχετε επιλέξει τα Windows να αποκρύπτουν τις επεκτάσεις γνωστών 
τύπων αρχείων. Αυτό δεν είναι πρόβλημα. Παραβλέψτε την επέκταση που 
αναφέρεται και ψάξτε το αρχείο μόνο με το όνομα του κύριου μέρους. 

Για τις ανάγκες των μαθημάτων δημιουργήθηκαν τα βοηθητικά αρχεία 
Cameraxy με το x να δείχνει σε πιο μάθημα αναφέρεται το συγκεκριμένο αρχείο και 
το y  αν είναι στην έναρξη του μαθήματος (0) ή η κατάληξή του (1). Π.χ. το αρχείο 
Camera101 αναφέρεται στο 10ο μάθημα, στο τέλος (είναι δηλαδή η τελική μορφή). 

Και μερικές γενικές αλήθειες 
Στα μαθήματα αυτά όλα είναι έτοιμα. Πατήστε αυτό το κουμπί, βάλτε αυτή την 

εικόνα, εισάγετε αυτό τον ήχο ή εκείνο το βίντεο. Στην πράξη, όταν θα έχετε να 
σχεδιάσετε τη δική σας εφαρμογή, θα είσαστε ΕΣΕΙΣ που θα αποφασίσετε τι θα μπει 
που, τι θα γραφεί σε κάθε ενότητα και με ποια σειρά, τι θα εμφανιστεί πότε. Και αυτό 
είναι πολύ πιο δύσκολο από το να πρέπει πατάτε μερικά κουμπιά στη σειρά. 

Να θυμάστε πάντα ότι το αποτέλεσμα δεν εξαρτάται από τα πολλά εφέ και τα 
έντονα χρώματα αλλά από την προσοχή στη λεπτομέρεια. Στη συγκεκριμένη 
εφαρμογή, γίνονται πολλά και σε αρκετό βάθος. Το αποτέλεσμα (αν και απλό) είναι 
αρκετά εντυπωσιακό, αρκεί να προσεχτεί στην κατασκευή. 

Μην αφήσετε, στην εφαρμογή σας, κάτι που δεν πήγε καλά. Επαναλάβετε τα 
(καθοδηγούμενα) βήματα. Μην πείτε ότι αυτή η εφαρμογή είναι εκπαιδευτική και πως 
όταν θα φτιάξετε τη δική σας όλα θα πάνε καλά. Κατανοείστε το τι γίνεται σε κάθε 
βήμα και ποια διαφοροποίηση φέρνει η κάθε επιλογή. Ρωτήστε γιατί γίνεται κάτι που 
δεν καταλαβαίνετε. Μόνο τότε θα μπορείτε όταν θα εργάζεστε στη δική σας εφαρμογή 
να μπορείτε να ανατρέχετε (είτε από μνήμης είτε από τις σημειώσεις) σε αντίστοιχα 
προβλήματα που παρουσιάστηκαν και στον τρόπο λύσης τους. 

Καλή συνέχεια. 
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Μάθημα 1ο. 

Ξεκινώντας με το AuthorWare. 
1. Ξεκινήστε το AuthorWare. Κάντε κλικ οπουδήποτε στην εισαγωγική οθόνη για 

να αρχίσετε. Αν έχετε δοκιμαστική έκδοση επιλέξτε “Try”. 
2. Ξεκινήστε αποθηκεύοντας την εφαρμογή που θα φτιάξετε δίνοντάς της ένα 

όνομα. Το “Camera” φαίνεται κατάλληλο.  

Δημιουργώντας μια οθόνη τίτλου 
3. Σύρτε ένα εικονίδιο display στο χώρο εργασίας σας και ονομάστε το Τίτλος. 
4. Κάντε διπλό κλικ στο εικονίδιο που  μόλις εισάγατε. Θα εμφανιστεί το toolbox 

γραφικών με το όνομα “Τίτλος” στο πάνω μέρος του. 
5. Μετακινείστε το toolbox στην πάνω δεξιά γωνία, ώστε να σας αφήνει ελεύθερο 

τον κατάλληλο χώρο για εργασία. 

Εισάγοντας κείμενο  
6. Επιλέξτε το εργαλείο κειμένου (Text - με το Α) από το toolbox. 
7. Για να αλλάξετε την γραμματοσειρά επιλέξτε “Text -> Fonts -> Other -> Arial 

Greek”. Επιλέγοντας αλλαγή γραμματοσειράς  χωρίς να έχουμε επιλεγμένο 
κείμενο, αλλάζουμε την default γραμματοσειρά για όλο το αρχείο. 

8. Τοποθετήστε τον κέρσορα κάπου στο κέντρο της οθόνης και γράψτε: Ο κόσμος 
των φωτογραφικών μηχανών 35mm. 

9. Για να αλλάξτε το μέγεθος (ή το περιεχόμενο του κειμένου) που μόλις γράψατε 
επιλέξτε το κείμενο που θέλετε και επιλέξτε “Text -> Size” και διαλέγετε ότι 
θέλετε. Στη συγκεκριμένη περίπτωση θέστε το στις 14 στιγμές. 

10. Προσαρμόστε το πλάτος του κειμένου στενεύοντάς το. Για να γίνει αυτό σύρτε 
προς τα αριστερά το δεξί άσπρο τετραγωνάκι. Τα σημαδάκια πάνω στη γραμμή 
θυμίζουν τα αντίστοιχα του επεξεργαστή κειμένου (π.χ. Word). 

11. Αποθηκεύστε. 

Δημιουργώντας Γραφικά 
12. Φτιάξτε ένα πλαίσιο γύρω από το κείμενο. Γι’ αυτό επιλέξτε το εργαλείο 

ορθογωνίου από το toolbox (Rectangle). 
13. Βάλτε ένα γέμισμα στο πλαίσιο που φτιάξατε. Για να εμφανίσετε το εργαλείο 

γεμισμάτων πατήστε control - D (ή κάντε διπλό κλικ σ’ ένα από τα 4 κλειστά 
σχήματα στην κάτω σειρά του toolbox) και διαλέξτε το 5ο στην 1η στήλη. 

14. Ας βάλουμε και λίγο χρώμα. Πατήστε control - K και διαλέξτε ένα σκούρο μπλε. 
15. Για να φαίνεται το κείμενο επιλέξτε “Modify -> Send to back”. 
16. Τώρα το πλαίσιο κειμένου φαίνεται άσπρο και δεν είναι καλό το αποτέλεσμα. Αν 

το κάνουμε διάφανο το πράγμα θα βελτιωθεί. Για να γίνει αυτό επιλέξτε το, 
πατήστε control - M (ή κάντε διπλό κλικ στο βελάκι του toolbox) και διαλέξτε 
Transparent. 

17. Αυτό που μέχρι τώρα φτιάξαμε αποτελείται από δυο κομμάτια. Ένα το πλαίσιο 
κειμένου και ένα το ορθογώνιο. Για να τα ενοποιήσουμε ώστε να μετακινούνται 
μαζί, έχοντας επιλέξει το εργαλείο κατάδειξης (Pointer - βελάκι) κάντε ένα 
πλαίσιο με το ποντίκι σας γύρω από τα δυο αυτά αντικείμενα (ή πατήστε με το 



AuthorWare 5: Οδηγίες Δημιουργίας Εφαρμογής Γιάννης Μαλλιαρός 

Σελίδα 4  Μαθήματα AuthorWare 

ποντίκι σας πάνω τους διαδοχικά κρατώντας πατημένο το Shift). Για να είστε 
σίγουροι ότι έχουν επιλεγεί και τα δυο θα δείτε ότι εμφανίζονται δύο ομάδες 
χειριστηρίων γύρω από τα αντικείμενα. 

18. Επιλέξτε “Modify -> Group”. 
19. Επιλέξτε “Control -> Play”. Θα δείτε αυτό που έχετε φτιάξει μέχρι τώρα. 

Αποθηκεύστε. 

Ρυθμίζοντας την γενική εμφάνιση 
20. Επιλέξτε “Modify -> File -> Properties”. Επιλέξτε σαν μέγεθος το “Variable”. 

Ξετσεκάρετε την εμφάνιση της μπάρας των μενού. 
21. Επιλέξτε “Control -> Restart". Δείτε πως εμφανίζετε τώρα η οθόνη. 
22. Τσεκάρετε ξανά την εμφάνιση της μπάρας των μενού καθώς επίσης και το 

κεντράρισμα της παρουσίασης στην οθόνη του χρήστη. 

Προσθέτοντας εικονίδια 
23. Τοποθετήστε ένα δεύτερο εικονίδιο display  μετά το πρώτο. Ονομάστε το: 

Φωτομηχανή. 
24. Τοποθετήστε ένα εικονίδιο wait μετά. Δεν χρειάζεται να το ονομάσετε (και το 

AuthorWare δεν το ονομάζει). 
25. Κατόπιν τοποθετήστε ένα εικονίδιο erase. Ονομάστε το: Διαγρ. Φωτομ.. 
26. Αποθηκεύστε. Επιλέξτε “Control -> Restart". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Το AuthorWare θα σας ζητήσει να προσδιορίσετε τι θα παρουσιάζεται στο 
display “Φωτομηχανή”. 

Εισάγοντας εικόνες 
27. Επιλέξτε “Insert -> Image". Επιλέξτε “Import” και διαλέξτε να εισάγετε το αρχείο 

“Camside.bmp”.  
28. Μετακινήστε τη φωτογραφική μηχανή στην κάτω δεξιά γωνία (Αφήστε ένα 

περιθώριο περίπου δύο εκατοστών). 
29. Κάντε κοντρόλ κλικ (ή διπλό κλικ) στο πλαίσιο του Τίτλου για να ανοίξετε για 

επεξεργασία το αντίστοιχο display. 
30. Μετακινείστε τον τίτλο δίπλα στην εικόνα της φωτογραφικής μηχανής. 
31. Επιλέξτε “Control -> Restart". Το AuthorWare θα εμφανίσει το πλήκτρο 

“Continue”. Ας το κάνουμε Ελληνικό. 
32. Επιλέξτε “Modify -> File -> Properties”. Επιλέξτε “Interaction” και στο Label 

γράψτε: Συνέχεια. 
33. Επιλέξτε “Control -> Pause". Μετακινείστε το πλήκτρο συνέχειας στο κάτω δεξιό 

μέρος της οθόνης. 

Διαγράφοντας εικόνες 
34. Επιλέξτε “Control -> Restart". Πατήστε στο πλήκτρο “Συνέχεια” ή οποιοδήποτε 

πλήκτρο του πληκτρολογίου. Το AuthorWare θα συναντήσει το εικονίδιο 
διαγραφής και έτσι θα εμφανίσει το παράθυρο ιδιοτήτων του για να του πούμε τι 
θα διαγράψει. 

35. Κάντε κλικ σ’ ένα οποιοδήποτε σημείο στην εικόνα της μηχανής και κατόπιν 
επιλέξτε “OK”. 
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36. Αποθηκεύστε.  

Βάζοντας ειδικά εφέ 
37. Επιλέξτε “Control -> Restart". Πατήστε στο πλήκτρο “Συνέχεια”. 
38. Τοποθετήστε ένα εικονίδιο erase πριν από το εικονίδιο erase “Διαγρ. Φωτομ.”. 

Ονομάστε το: Διαγρ. Τίτλου. 
39. Επιλέξτε “Control -> Restart". Πατήστε στο πλήκτρο “Συνέχεια”. 
40. Όταν ρωτήσει τι να διαγράψει κάντε κλικ σ’ ένα οποιοδήποτε σημείο του 

κειμένου (ή του πλαισίου του).  
41. Από την επιλογή “Transition” πατήστε το πλήκτρο με τις τρεις τελείες επιλέξτε 

“Mosaic”, και κατόπιν επιλέξτε δυο φορές “OK”. Αποθηκεύστε.  

Ομαδοποιώντας εικονίδια 
42. Επιλέξτε “Control -> Restart".  
43. Επιλέξτε όλα τα εικονίδια που έχετε τοποθετήσει μέχρι τώρα σύροντας το 

ποντίκι σας ώστε να σχηματίσει ένα πλαίσιο γύρω απ’ αυτά. 
44. Επιλέξτε “Modify -> Group”. 
45. Ονομάστε το εικονίδιο map που μόλις δημιουργήθηκε σαν: Εισαγωγή. 
46. Κάντε διπλό κλικ στο εικονίδιο. Θα ανοίξει και παρατηρήστε ότι αναφέρει ότι 

είναι στο επίπεδο 2 (Lever 2). 
47. Κλείστε το και αποθηκεύστε. 
48. Επιλέξτε “Control -> Play”. Θα δείτε αυτό που έχετε φτιάξει μέχρι τώρα. Όταν 

εμφανιστεί το πλήκτρο “Συνέχεια” κάντε κλικ πάνω του. 
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Μάθημα 2ο. 

Δομώντας ένα περιβάλλον αλληλεπίδρασης 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart". Δοκιμάστε την 

εφαρμογή μέχρι εδώ. 
2. Εισάγετε ένα εικονίδιο display και ονομάστε το: Πάνω Μέρος. 
3. Κάντε διπλό κλικ στο εικονίδιο που μόλις εισάγατε ώστε να ανοίξει για 

επεξεργασία. 
4. Εισάγετε την εικόνα «CamTop.Bmp». 
5. Μετακινήστε τη φωτογραφική μηχανή στην κάτω δεξιά γωνία (Αφήστε ένα 

περιθώριο περίπου δύο εκατοστών). 
6. Αμέσως κάτω από το εικονίδιο display «Πάνω Μέρος» εισάγετε ένα εικονίδιο 

interaction και ονομάστε το: Κλικ. 
7. Εισάγετε ένα εικονίδιο display δεξιά στο εικονίδιο interaction και ονομάστε το: 

Κλείστρο. Στην ερώτηση τι είδους ενέργεια να περιμένει επιλέξτε “Hot Spot” 
(Δηλ. θερμή περιοχή όπου ένα κλικ θα μας εμφανίζει το περιεχόμενο του 
συγκεκριμένου display). Ένα διάστικτο παραλληλόγραμμο εμφανίζεται στο 
σημείο σύνδεσης του εικονιδίου display με το εικονίδιο interaction. 

8. Εισάγετε δυο ακόμα εικονίδια display δεξιά στο εικονίδιο display «Κλείστρο». 
Ονομάστε τα Φακός και Διάφραγμα αντίστοιχα. 

Συμπληρώνοντας ένα interaction  
9. Σύρτε την εικόνα της λευκής σημαίας (flag) με την ένδειξη start και τοποθετήστε 

την πάνω από το εικονίδιο display «Πάνω μέρος». 
10. Επιλέξτε “Control -> Restart from Flag". Θα εμφανιστεί το πάνω μέρος μιας 

φωτογραφικής μηχανής. 
11. Kάντε διπλό κλικ στο εικονίδιο interaction «Κλικ» έχοντας πατημένο το πλήκτρο 

shift του πληκτρολογίου. Θα ανοίξει το παράθυρο του interaction «Κλικ» χωρίς 
να φύγει η εικόνα που εμφανιζόταν προηγούμενα. 

12. Σύρτε τις θερμές περιοχές που εμφανίζονται και τοποθετήστε τις γύρω από τα 
αντίστοιχα σημεία της μηχανής. 

13. Προσαρμόστε το μέγεθός τους ώστε να καλύπτουν ολόκληρο το θέμα που 
αναφέρονται (π.χ. η περιοχή «Φακός» να καλύπτει όλο το φακό) χωρίς όμως να 
επεκτείνονται και σε άλλα σημεία (π.χ. η περιοχή κλείστρο πρέπει  να είναι 
σφιχτά γύρο από το κόκκινο κουμπί που τραβάει φωτογραφίες). 

14. Γράψτε στο αριστερό μέρος της μηχανής: Κάνε κλικ στο σημείο που πρέπει να 
πιέσεις για να πάρεις μια φωτογραφία. Προσαρμόστε κατάλληλα το μέγεθος του 
πλαισίου κειμένου. 

15. Αποθηκεύστε 

Εξασφαλίζοντας την ανάδραση 
16. Επιλέξτε “Control -> Restart from Flag". 
17. Καθώς θα σας προτρέπει να κάντε κλικ στο κλείστρο, εσείς πατήστε πάνω στο 

φακό. Αυτό θα σας οδηγήσει στο display «Φακός» όπου και θα πρέπει να 
πληροφορήσετε το χρήστη ότι έκανε μια λαθεμένη επιλογή. (Παρατηρήστε ότι 
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όταν είσαστε σε κατάσταση επεξεργασίας, εμφανίζεται το toolbox το οποίο και 
σας πληροφορεί σε ποιο τμήμα – εικονίδιο δουλεύετε). 

18. Χρησιμοποιώντας το εργαλείο κειμένου γράψτε κάτω από την προτροπή (χωρίς 
να την επικαλύπτετε): Λάθος. Αυτός είναι ο φακός. Χρησιμοποιείται για να 
μπαίνει το φως στο φιλμ. Προσπάθησε ξανά.. 

19. Τροποποιήστε τα περιθώρια του κειμένου. 
20. Επιλέξτε το δείκτη (Pointer) για να βγείτε από την κατάσταση επεξεργασίας 

κειμένου. Πατήστε control - L για να εμφανιστεί το εργαλείο ορισμού πλάτους 
γραμμών (ή κάντε διπλό κλικ σε μια από τις γραμμές δεξιά στο πάνω μέρος του 
toolbox)και διαλέξτε μια σχετικά παχύτερη γραμμή (π.χ. την Τρίτη από πάνω). 
Βεβαιωθείτε ότι από το κάτω τμήμα είναι επιλεγμένη η απλή γραμμή. 

21. Επιλέξτε το εργαλείο ορθογωνίου από το toolbox (Rectangle) και φτιάξτε ένα 
ορθογώνιο γύρω από το φακό. Επειδή θα σας το βγάλει με γέμισμα (όπως 
είχαμε κάνει την τελευταία φορά) διαλέξτε να εξαλείψετε το γέμισμα. (Διπλό κλικ 
στο εργαλείο Rectangle και επιλογή None. 

22. Κλείστε τα toolbox που εμφανίζονται. Κλείνοντας το βασικό toolbox βγαίνουμε 
από την κατάσταση επεξεργασίας. 

23. Επιλέξτε “Control -> Restart from Flag". 
24. Αυτή τη φορά πατήστε πάνω στο δαχτυλίδι του διαφράγματος. Αυτό θα σας 

οδηγήσει στο display «Διάφραγμα» όπου πάλι θα πρέπει να πληροφορήσετε το 
χρήστη ότι έκανε λαθεμένη επιλογή. 

25. Χρησιμοποιώντας το εργαλείο κειμένου γράψτε κάτω από την προτροπή: 
Λάθος. Αυτό είναι για τη ρύθμιση του διαφράγματος. Ρυθμίζει το πόσο φως θα 
μπει στη μηχανή. Προσπάθησε ξανά.. 

26. Τροποποιήστε τα περιθώρια του κειμένου. 
27. Επιλέξτε το εργαλείο ορθογωνίου από το toolbox και φτιάξτε ένα ορθογώνιο 

γύρω από το δαχτυλίδι του διαφράγματος. 
28. Επιλέξτε “Control -> Restart from Flag". 
29. Τώρα πατήστε πάνω στο κουμπί του κλείστρου. Αυτό θα σας οδηγήσει στο 

display «Κλείστρο» όπου πάλι θα πρέπει να επιβραβεύσετε το χρήστη για τη 
σωστή του επιλογή. 

30. Γράψτε κάτω από την προτροπή: Πολύ σωστά. Πιέζοντας το κουμπί, ανοίγει το 
κλείστρο για να αφήσει το φως να περάσει από το φακό και να επιδράσει στο 
φιλμ.. 

31. Τροποποιήστε τα περιθώρια του κειμένου. 
32. Επιλέξτε το εργαλείο έλλειψης (Ellipse) από το toolbox και φτιάξτε ένα κύκλο 

γύρω από το κουμπί του κλείστρου. Για να βγει τέλειος ο κύκλος κρατάτε 
πατημένο το πλήκτρο shift όταν τον σχεδιάζετε. 

33. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
34. Αποθηκεύστε. 
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Μάθημα 3ο. 

Ολοκληρώνοντας ένα interaction  
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  display «Κλείστρο» και 

interaction «Κλικ». Θα μας ανοίξει το πλαίσιο διαλόγου των ιδιοτήτων της 
ανταπόκρισης του display «Κλείστρο». 

3. Δείξτε ότι η επιλογή της συγκεκριμένης απάντησης είναι η σωστή. Για να γίνει 
αυτό επιλέξτε “Correct Response” από το πλαίσιο επιλογών “Status”. (Αυτό 
μπορεί να το χρησιμοποιήσουμε αν θέλουμε για να βαθμολογήσουμε αργότερα 
το χρήστη). 

4. Αν κάποιος κάνει τη σωστή επιλογή δεν χρειάζεται να περιμένει άλλο. Επιλέξτε 
λοιπόν “Exit interaction” από το πλαίσιο επιλογών “Branch”. 

5. Πατήστε «OK». Παρατηρήστε ότι ένα + έχει εμφανιστεί πριν από το όνομα του 
display «Κλείστρο». Επίσης ότι στο κάτω μέρος η γραμμή ροής είναι στραμμένη 
προς τα αριστερά και βγαίνει από τον βρόγχο του interaction. 

6. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  display «Φακός» και 
interaction «Κλικ». 

7. Επιλέξτε “Wrong Response” από το πλαίσιο επιλογών “Status”. 
8. Κάντε το ίδιο και για το εικονίδιο display «Διάφραγμα». 

Εμπλουτίζοντας ένα interaction  
9. Εισάγετε ένα εικονίδιο display δεξιά από το εικονίδιο display «Διάφραγμα». 

Ονομάστε το: Βοήθεια. 
10. Επιλέξτε να είναι τύπου “Button” ενώ επιλέξτε το “Status” να είναι “Not Judged”. 
11. Μετακινείστε το πλήκτρο «Βοήθεια» που θα εμφανιστεί στην οθόνη στα 

αριστερά του κάτω μέρους τροποποιώντας το μέγεθός του (μικρύνετε το). 
12. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
13. Κάντε κλικ στο πλήκτρο «Βοήθεια». Αυτό θα σας βγάλει στο display «Βοήθεια». 
14. Φτιάξτε ετικέτες για κάθε ένα από τα επίμαχα σημεία(φακός, διάφραγμα, 

κλείστρο). 
15. Τοποθετήστε τις ετικέτες σε κατάλληλα σημεία της οθόνης γύρω από τη 

μηχανή. 
16. Φτιάξτε γραμμές - οδηγούς που να δείχνουν για την κάθε ετικέτα το αντίστοιχο 

αντικείμενο. 
17. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
18. Αποθηκεύστε. 
19. Εισάγετε ένα εικονίδιο display ανάμεσα από το εικονίδιο display «Διάφραγμα» 

και το εικονίδιο display Βοήθεια» και ονομάστε το: Σώμα. Θα δείτε ότι αυτό 
παίρνει τις ρυθμίσεις σύνδεσης του εικονιδίου που βρίσκεται ακριβώς αριστερά 
του. 

20. Επιλέξτε “Control -> Restart from Flag". Επιλέξτε “Control -> Pause" (ή πατήστε 
control – P). 
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21. Ρυθμίστε το μέγεθος της περιοχής ανταπόκρισης «Σώμα» ώστε να καλύπτει όλο 
το σώμα της μηχανής. Προσέξτε να μην υπάρχει μέρος της εικόνας ακάλυπτο, 
αλλά και να μην υπάρχουν επικαλύψεις. Βέβαια, δεν είναι δυνατόν η επιλογή 
«Σώμα»  να μην καλύπτει την επιλογή «Κλείστρο». Αυτό δεν θα δημιουργήσει 
πρόβλημα, καθώς αυτή η τελευταία προηγείται στη δομή μας. Αντίθετα, δεν 
πρέπει να καλυφθεί το πλήκτρο «Βοήθεια». 

22. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Κάντε κλικ σ’ οποιοδήποτε σημείο της μηχανής. Θα σας βγάλει στο 
Presentation Window του display “Σώμα”, που θα εμφανίζεται όταν κάνουμε κλικ 
στη μηχανή. 

23. Διαλέξτε το εργαλείο του κειμένου και γράψτε: Λάθος. Δεν είναι αυτό το σωστό 
σημείο. Προσπάθησε ξανά.. 

24. Μικρύνετε το πλαίσιο του κειμένου και κλείστε το toolbox. 
25. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Αποθηκεύστε. 
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Μάθημα 4ο. 

Δομώντας ένα interaction  απάντησης κειμένου 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. Το πρόβλημά είναι ότι όταν δοθεί η σωστή απάντηση, 
εξαφανίζεται αμέσως το display “Κλείστρο”, μ’ αποτέλεσμα ο χρήστης να μην 
μπορεί αν διαβάσει το τι του λέτε. 

2. Πατήστε στο εικονίδιο interaction “Κλικ” και επιλέξτε "Modify -> Icon -> 
Properties". Στο πλαίσιο διαλόγου που θα εμφανιστεί επιλέξτε ”Pause Before 
Exiting” που θα σταματάει το display πριν κλείσει και “Show Button” ώστε να 
βγάλει το σχετικό εικονίδιο για να μπορούμε να συνεχίσουμε. 

3.  Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Αν 
όλα πάνε καλά αποθηκεύστε την. 

4. Βάλτε ένα ακόμα εικονίδιο interaction και ονομάστε το: Τι είναι το 125; 
5. Προσθέστε του ένα display. Επιλέξτε η σύνδεσή του να είναι της μορφής Text 

Entry. 
6. Ονομάστε το: Ταχύτητα. 
7. Προσθέστε στα δεξιά ένα ακόμα display που να το ονομάσετε: *. 
8. Κάντε διπλό κλικ στο display “Πάνω μέρος” και κλείστε το toolbox. 
9. Κάντε διπλό κλικ στο interaction “Τι είναι το 125;” έχοντας πατημένο το shift. Μ’ 

αυτό τον τρόπο θα μπούμε στην επεξεργασία του interaction έχοντας όμως και 
την εικόνα της μηχανής (για να ξέρουμε που γράφουμε. 

10. Επιλέξτε το εργαλείο κειμένου και γράψτε πάνω από το σημαδάκι για την 
εισαγωγή του κειμένου: Τι σημαίνει ο αριθμός 125 που φαίνεται στη μηχανή; 

11. Στενέψτε το πλαίσιο του κειμένου. 
12. Επιλέξτε το βελάκι και μετά το πλαίσιο για την εισαγωγή του κειμένου από το 

χρήστη. Αλλάξτε το μέγεθος (να είναι αρκετό) και τη θέση ώστε να συμβαδίζει 
με το από πάνω του κείμενο. 

13. Κλείστε το toolbox. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την 
εφαρμογή μέχρι εδώ. 

14. Όταν σας ζητήσει κείμενο γράψτε: Αναφέρετε στην ταχύτητα του κλείστρου. (τη 
σωστή απάντηση δηλ.) 

15. Γράψτε από κάτω την απόκριση στην (σωστή) απάντηση του χρήστη: Σωστά. 
Δείχνει την ταχύτητα του κλείστρου σαν κλάσμα  δευτερολέπτων. Στο 
συγκεκριμένο παράδειγμα το κλείστρο θα μείνει ανοιχτό για 1/125 sec. 

16. Προσαρμόστε τα περιθώρια του κειμένου. Επιλέξτε “Control -> Restart from 
Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ.  

17. Όταν σας ζητήσει απάντηση γράψτε κάτι άσχετο (π.χ. το όνομά σας) και 
πατήστε Enter. Θα σας βγάλει στο display που έχουμε ονομάσει *.  

18. Δώστε την απόκριση για την (λάθος) απάντηση: Όχι. Σκέψου ότι είναι το 1/125 
δευτερόλεπτα. 

19. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Αν 
όταν δίνετε λάθος απάντηση σκεπάζεται το σημείο εισαγωγής διορθώστε. 
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20. Πατήστε στο εικονίδιο interaction “Τι είναι το 125;” και επιλέξτε "Modify -> Icon  -
> Properties". Στο πλαίσιο διαλόγου που θα εμφανιστεί επιλέξτε ”Pause Before 
Exiting” και “Show Button”. 

21. Πατήστε “Text Field” και αλλάξτε τη γραμματοσειρά σε Courier. 
22. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ.  
23. Κάντε control κλικ στο κάτω μέρος του display “Ταχύτητα”. 
24. Κάντε control κλικ στο δεξί μέρος του ονόματος του display “Ταχύτητα”. 
25. Κάντε δυο φορές control κλικ στο δεξί μέρος του ονόματος του display “*”. 
26. Αλλάξτε το όνομα του display “Ταχύτητα” σε “Ταχ?τητα” για να πιάνουμε και τα 

μικρά και τα κεφαλαία. 
27. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Μετακινήστε το πλήκτρο για τη συνέχεια σε σημείο που να μην ενοχλεί (στη 
μέση κάτω). Αποθηκεύστε. 

Τροποποιώντας ένα interaction  
28. Προσθέστε ένα ακόμα display ανάμεσα στα 2 προηγούμενα και ονομάστε το: 2 

φορές. 
29. Κάντε διπλό κλικ στο είδος σύνδεσης και αλλάξτε το σε “Tries Limit” και ορίστε 

σε 2 το όριο προσπαθειών. 
30. Βάλτε τη σημαία έναρξης πριν από το interaction “Τι είναι το 125;”. Επιλέξτε 

“Control -> Restart from Flag". 
31. Δώστε 2 λάθος απαντήσεις. Θα σας βγάλει το Presentation Window του display 

“2 φορές”. 
32. Με το εργαλείο κειμένου γράψτε την απόκριση: Η σωστή απάντηση είναι 

ταχύτητα κλείστρου. Ας προχωρήσουμε όμως. 
33. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Αποθηκεύστε. 

Μόνιμη εμφάνιση 
34. Κάντε διπλό κλικ στο σημείο σύνδεσης του display “Βοήθεια”. Επιλέξτε “Return” 

στην επιλογή “Branch” ώστε να επιστρέφει το χρήστη κάθε φορά στο 
προηγούμενο μετά τη βοήθεια που θα πάρει. 

35. Βάλτε τη σημαία έναρξης πριν από το display “Επάνω μέρος”. Επιλέξτε “Control 
-> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

36. Βάλτε ένα εικονίδιο erase μετά το interaction “Τι είναι το 125;” και ονομάστε το: 
Πάνω μέρος και βοήθεια. Αν χρειάζεστε περισσότερο χώρο τραβήξτε το κάτω 
μέρος του χώρου εργασίας. 

37. Επιλέξτε “Control -> Restart from Flag". Όταν σας ρωτήσει τι να διαγράψει 
επιλέξτε την εικόνα της μηχανής και το πλήκτρο της βοήθειας. 

38. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Αν 
όλα πάνε καλά, κάντε ένα ιδεατό πλαίσιο γύρω από όσα φτιάξαμε μέχρι τώρα 
(εκτός από την “Εισαγωγή”). Επιλέξτε ”Modify -> Group” και ονομάστε το: Μέρη 
μηχανής. 

39. Αποθηκεύστε την εφαρμογή. 
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Μάθημα 5ο. 

Δομώντας ένα μενού οθόνης 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Αν το παράθυρο σχεδίασης εφαρμογής δεν είναι ορατό, κάντε κλικ σ’ αυτό ή 

επιλέξτε “View -> Current Icon ". 
3. Βάλτε ένα εικονίδιο interaction στο τέλος της εφαρμογής και ονομάστε το: 

Επέλεξε. 
4. Βάλτε ένα εικονίδιο map δίπλα στο interaction και επιλέξτε να είναι της μορφής 

Hot Spot.  
5. Ονομάστε το: Ορολογία. 
6. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  map “Ορολογία” και 

interaction “Επέλεξε”. Στην επιλογή “Key(s)" πληκτρολογήστε 1. Αυτό θα δώσει 
τη δυνατότητα στο χρήστη να μπορεί να επιλέξει τη συγκεκριμένη επιλογή 
πατώντας απλά το 1 από το πληκτρολόγιο. 

7. Επιλέξτε το εικονίδιο map “Μέρη μηχανής” και επιλέξτε ”Edit -> Cut” (αποκοπή). 
8. Κάντε κλικ δεξιά από το εικονίδιο map “Ορολογία”. Θα εμφανιστεί ένα χεράκι 

που δείχνει που  θα συμβεί η επόμενη ενέργεια που θα κάνουμε. 
9. Επιλέξτε ”Edit -> Paste” (επικόλληση). Θα εμφανιστεί το εικονίδιο map “Μέρη 

μηχανής”. 
10. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  map “Μέρη μηχανής” και 

interaction “Επέλεξε”. Στην επιλογή “Key(s)" πληκτρολογήστε 2. 
11. Βάλτε ένα εικονίδιο map δεξιά στο “Μέρη μηχανής”  και ονομάστε το: Τράβα 

φωτογραφίες. 
12. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  map “Τράβα 

φωτογραφίες” και interaction “Επέλεξε”. Στην επιλογή “Key(s)" πληκτρολογήστε 
3. 

13. Βάλτε ένα εικονίδιο display δεξιά στο “Τράβα φωτογραφίες” και ονομάστε το: 
Έξοδος. 

14. Κάντε διπλό κλικ στο σημείο σύνδεσης των εικονιδίων  display “Έξοδος” και 
interaction “Επέλεξε”. Επιλέξτε η σύνδεση να είναι του τύπου “Button” και σαν 
“Brunch” το “Exit Interaction”. 

15. Αποθηκεύστε τις αλλαγές στο αρχείο σας. 

Χρησιμοποιώντας μοντέλα 
16. Κάντε διπλό κλικ στο εικονίδιο map “Ορολογία”. Θα ανοίξει ένα (κενό) παράθυρο 

εργασίας για το συγκεκριμένο map. 
17. Επιλέξτε “Window -> Knowledge Objects”. Ελέγξτε αν υπάρχει η κατηγορία 

“Trial”. Αν όχι θα την πάρετε από τη διεύθυνση \\server\server\My Documents 
και θα το αντιγράψετε στον κατάλογο C:\Program 
Files\Macromedia\AuthorWare 5\Knowledge Objects. Σ’ αυτή την περίπτωση 
μην ξεχάσετε να πατήσετε “Refresh” για να δει το AuthorWare την αλλαγή που 
έγινε. 
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18. Από τα Objects Trial επιλέξτε το μοντέλο “Terms”. Τα μοντέλα είναι τμήματα 
προγράμματος AuthorWare έτοιμα από κάποια άλλη φορά που μπορούμε να τα 
εισάγουμε στην εφαρμογή που φτιάχνουμε κατευθείαν. Μπορούμε να 
επιλέξουμε ένα οποιοδήποτε τμήμα απ’ αυτά που φτιάξαμε και να 
αποθηκεύσουμε τη δομή και το περιεχόμενό του σαν μοντέλο για να το 
χρησιμοποιήσουμε μιαν επόμενη φορά από την επιλογή “File -> Save in 
model”. Παρόμοια χρήση έχουν οι βιβλιοθήκες όπου αποθηκεύουμε μόνο το 
περιεχόμενο από τα εικονίδια. 

19. Σύρτε το εικονίδιο μπροστά από το μοντέλο “Terms” στην περιοχή εργασίας 
“Ορολογία”. Εξερευνήστε το τμήμα του προγράμματος που μόλις εισάγατε. 
Περιέχει ένα εικονίδιο decision με το όνομα “Επιλογή 3 αντικειμένων” το οποίο 
έχει ρυθμιστεί να εμφανίζει τρία (με τυχαία σειρά) από τα displays που το 
ακολουθούν. Μελετήστε τον τρόπο που είναι δομημένα τα maps στο 
συγκεκριμένο τμήμα. 

20. Βάλτε το flag “start” στην αρχή της περιοχής εργασίας “Ορολογία”. Επιλέξτε 
“Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Δείτε τις νέες 
δυνατότητες. Επαναλάβετε 2 – 3 φορές και δείτε ότι κάθε φορά παρουσιάζει τα 
θέματα με διαφορετική σειρά. 

21. Βγάλτε το flag “start” (αυτό μπορεί να γίνει είτε σέρνοντας τη σημαία στην 
εργαλειοθήκη είτε πατώντας στο χώρο που την κρατάμε). Κλείστε το map 
“Ορολογία”. 

22. Αποθηκεύστε τις αλλαγές στο αρχείο σας. 

Δημιουργώντας ένα μενού οθόνης 
23. Κάντε διπλό κλικ στο εικονίδιο interaction “Επέλεξε”. Εισάγετε το παρακάτω 

κείμενο πατώντας “Enter” στο τέλος της κάθε γραμμής και αφήνοντας μια κενή 
γραμμή ανάμεσα. Βάλτε ένα σημάδι στηλοθέτη (tab) περίπου 1 εκατοστό από 
την αρχή. (Κάντε κλικ πάνω στη γραμμή που μας παρουσιάζει όταν γράφουμε 
κείμενο και θα εμφανιστεί ένα ανάποδο τρίγωνο, σημάδι πως εκεί έχει οριστεί 
στηλοθέτης). Πατάτε το πλήκτρο tab μετά από κάθε αριθμό – τελεία. 

24. Προσαρμόστε το μέγεθος του πλαισίου κειμένου που δημιουργήσατε. 
25. Μετακινήστε και αλλάξτε το μέγεθος στις θερμές περιοχές ώστε να καλύπτουν 

το κείμενο που αντιστοιχεί στην κάθε μια. Για να το πετύχετε με λιγότερες 
κινήσεις μπορείτε πρώτα να φτιάξετε ένα ιδεατό πλαίσιο πάνω από τα προς 
μετακίνηση τμήματα ώστε να επιλεγούν και τα 3 και μετά να τα τοποθετήσετε 
στη θέση που θέλετε και να τους αλλάξετε το μέγεθος σε όλα μαζί. 

26. Μετακινείστε το πλήκτρο “Έξοδος” στο κάτω δεξιό μέρος της οθόνης (κάτω από 
το κείμενο και δεξιά). 

1. Φωτογραφική Ορολογία 
 
2. Τα μέρη της φωτογραφικής μηχανής 
 
3. Ας πάρουμε μερικές φωτογραφίες 
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27. Επιλέξτε “Insert -> Image " και πατήστε “Import”. Επιλέξτε να εισάγετε το αρχείο 
“Film.bmp”. Μετακινήστε το στο πάνω μέρος της οθόνης και στο κέντρο. 

28. Βάλτε το flag “start” πριν το interaction “Επέλεξε”. Επιλέξτε “Control -> Restart 
from Flag". Επιλέξτε το 2ο θέμα είτε με κλικ του ποντικιού είτε με το “2” του 
πληκτρολογίου. Κάτι δεν πάει καλά. 

29. Για να αντιμετωπίσετε το πρόβλημα κάντε κλικ στο interaction “Επέλεξε” και 
επιλέξτε "Modify -> Icon -> Properties". Ρυθμίστε το ώστε η διαγραφή του να 
γίνεται μετά από κάθε νέα εικόνα που θα εμφανίζεται. 

30. Για να μην φαίνεται και το πλήκτρο της εξόδου κάντε διπλό κλικ στο σημείο 
σύνδεσης των εικονιδίων  display “Έξοδος” και interaction “Επέλεξε”. Επιλέξτε 
“Hide When Inactive”. 

31. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 



Γιάννης Μαλλιαρός Οδηγίες Δημιουργίας Εφαρμογής στο AuthorWare 5 

Μαθήματα AuthorWare  Σελίδα 15 

Μάθημα 6ο. 

Εμφανίζοντας τιμές μεταβλητών 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Πατήστε στο πλήκτρο “Έξοδος”. Θα σας οδηγήσει στο αντίστοιχο άδειο display. 
3. Κάντε εισαγωγή του αρχείου εικόνας “Slide.bmp”. Φροντίστε αν τοποθετηθεί στο 

κέντρο περίπου της οθόνης παρουσίασης. 
4. Γράψτε από κάτω: Τώρα η ώρα είναι (μην ξεχάσετε να αφήσετε ένα κενό). 
5. Επιλέξτε “Window -> Variables ". Διαλέξτε την κατηγορία “Time” κι απ’ αυτήν την 

μεταβλητή “FullTime”. Επιλέξτε “Paste”. 
6. Γράψτε:  στις {Date}. και πατήστε Enter. 
7. Γράψτε:  Άρχισες να δουλεύεις στις {StartTime}. (πατήστε Enter) Κάντε κλικ για 

έξοδο. 
8. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Επειδή δεν προλαβαίνετε να δείτε τι γράφει κατά την έξοδο, ρυθμίστε το 
interaction “Επέλεξε” ώστε να σταματάει λίγο πριν την έξοδο (χωρίς να 
εμφανίζεται το πλήκτρο “Συνέχεια”). 

9. Για να ενημερώνεται συνέχεια το ρολόι επιλέξτε "Modify -> Icon -> Properties" και 
τσεκάρετε το “Update Displayed Variables”. Επιλέξτε “Control -> Restart from 
Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

10. Για μια πιο εντυπωσιακή έξοδο επιλέξτε από τις ιδιότητες της εξόδου “Don’t 
Erase” και τοποθετήστε αμέσως μετά ένα εικονίδιο διαγραφής το οποίο να 
ονομάσετε: Διαγρ. Εξόδου. 

11. Επιλέξτε "Modify -> Icon -> Transition" και διαλέξτε “SharkByte Transitions -> 
The Byte” (είναι με ήχο). Επιλέξτε “Control -> Restart from Flag". Κατά την έξοδο 
όταν σας ρωτήσει για το τι να διαγράψει επιλέξτε ό,τι φαίνεται από το display 
“Έξοδος”. 

12. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Χρησιμοποιώντας εικονίδια Calculation 
13. Για να μην μένει ανοιχτό παράθυρο στο τέλος, βάλτε στο τέλος της γραμμής 

εργασίας ένα εικονίδιο Calculation και ονομάστε το: Τέλος. 
14. Κάντε διπλό κλικ στο εικονίδιο και Επιλέξτε “Window -> Functions". Διαλέξτε την 

κατηγορία “General” κι απ’ αυτήν την συνάρτηση “Quit”. Διαβάστε για τις 
παραμέτρους που δέχεται. Επιλέξτε “Paste”. 

15. Επιλέξτε το “option”  και αντικαταστήστε το με την τιμή: 1 (Θυμηθείτε τι σημαίνει 
αυτό απ’ όσα μόλις διαβάσατε στην περιγραφή της μεταβλητής). 

16. Κλείστε το παράθυρο των υπολογισμών και όταν σας ρωτήσει αν θέλετε να 
αποθηκεύσετε τις αλλαγές που μόλις κάνατε απαντήστε προφανώς καταφατικά. 

17. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Αν 
μείνετε ικανοποιημένοι αποθηκεύστε. 
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Κατασκευάζοντας τις ρυθμίσεις διαφράγματος 
18. Ανοίξτε το εικονίδιο map “Μέρη μηχανής”. Κάντε δεξί κλικ στο εικονίδιο display 

“Πάνω μέρος”. Θα εμφανιστεί το κύριο περιεχόμενο του συγκεκριμένου display. 
Αν κάνουμε κλικ οπουδήποτε εξαφανίζεται.  

19. Επιλέξτε "Modify -> Icon -> Properties". Στο αριστερό μέρος βλέπετε τις σχετικές 
πληροφορίες για το μέγεθος της εικόνας, το πότε το τροποποιήσατε και ότι άλλο 
σχετικό με το συγκεκριμένο εικονίδιο. Επίσης μια πολύ μικρή προεπισκόπησή 
του. 

20. Αντιγράψτε το συγκεκριμένο εικονίδιο (display “Πάνω μέρος”) και κάντε 
επικόλληση στην αρχή στο  εικονίδιο map “Τράβα Φωτογραφίες”. 

21. Εισάγετε ένα εικονίδιο decision. Ονομάστε το Διάφραγμα. Ρυθμίστε το στην 
επιλογή Repeat “Until All Paths Used”. 

22. Εισάγετε δεξιά του ένα εικονίδιο display με το όνομα f2.8. Επιλέξτε τη σύνδεσή 
του με το  εικονίδιο decision «Διάφραγμα». Επιλέξτε να μην διαγράφετε το 
περιεχόμενό του με την έξοδο (Don’t Erase). 

23. Εισάγετε δεξιά του 4 επιπλέον εικονίδια display με αντίστοιχο όνομα f4, f5.6, f8, 
f11. 

24. Τοποθετήστε τη σημαία έναρξης στην αρχή της περιοχής εργασίας του map 
“Τράβα Φωτογραφίες” και τη σημαία τέλους στο τέλος της. Επιλέξτε “Control -> 
Restart from Flag". Θα σας σταματήσει στο display  “f2.8”. 

25. Εισάγετε το αρχείο εικόνας “fstop2-8.bmp”. Τοποθετείστε την εικόνα ακριβώς 
πάνω στο δαχτυλίδι του διαφράγματος. (ΠΡΟΣΟΧΗ να μην ξεφεύγει καθόλου). 

26. Επειδή φαίνεται μια άσπρη γραμμή γύρω – γύρω, επιλέξτε "Modify -> Image 
Properties". Και διαλέξτε ο τρόπος ένθεσης να είναι “Matted”. 

27. Κλείστε το Toolbox ώστε να εμφανιστεί το επόμενο display. 
28. Εισάγετε και τις υπόλοιπες εικόνες στα αντίστοιχα display. Ρυθμίστε τον τρόπο 

εμφάνισης και την μικροτοποθέτηση. Για να κάνετε μικρές μετακινήσεις (αν δεν 
τα καταφέρνετε με το ποντίκι) μετακινείστε τις εικόνες σας με τα βελάκι του 
πληκτρολογίου.  

29. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Θα 
δείτε το δαχτυλίδι να γυρίζει εμφανίζοντας όλα τα ενδιάμεσα f-stop. 

30. Επιλέξτε το εικονίδιο decision και όλα τα εικονίδια που εξαρτώνται απ’ αυτό. 
Επιλέξτε “Modify -> Group". Μετονομάστε το εικονίδιο map που θα δημιουργηθεί 
σε fstops. Το AuthorWare ονομάζει ένα γκρουπ που αποτελείται μόνο από ένα 
εικονίδιο  decision και τα εικονίδια display που εξαρτώνται απ’ αυτό με το όνομα 
του decision. 
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Μάθημα 7ο. 

Κατασκευάζοντας τις ρυθμίσεις ταχύτητας 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Αν δεν φαίνεται η περιοχή εργασίας του map “Τράβα Φωτογραφίες” εμφανίστε 

την κάνοντας διπλό κλικ στα κατάλληλα εικονίδια. 
3. Ανάμεσα στο εικονίδιο display “Πάνω Μέρος” και στο εικονίδιο map “fstops” 

εισάγετε ένα εικονίδιο Digital Movie με το όνομα: Ταχύτητα κλείστρου. 
4. Κάντε διπλό κλικ στο εικονίδιο που μόλις τοποθετήσατε και πατήστε “Import…” 

Από τον κατάλογο speed θα εισάγεται τη σειρά εικόνων bitmap “Spee00??.bmp” 
(επιλέγετε το πρώτο εικονίδιο και επειδή είναι σειρά το AuthorWare θα τα πάρει 
μέχρι τέλος). Από τα “Options” αποεπιλέξτε το “Use black as the transparent 
color” εάν είναι επιλεγμένο. Επιλέξτε να είναι “Matted” ο τρόπος ένθεσης και 
όσον αφορά το “Concurrency” (σύμπτωση) να είναι “Perpetual” (συνεχής, 
διαρκής). Επίσης να επαναλαμβάνεται για συγκεκριμένες φορές στο “Play” και 
πληκτρολογήστε τον αριθμό 1 ακριβώς από κάτω. Ρυθμίστε να παίζει με ρυθμό 
30 fps και να προβάλει κάθε ένα καρέ (Play Every Frame). 

5. Μετακινείστε το πλαίσιο της εικόνας που μόλις τοποθετήσατε, έτσι ώστε να 
συμπίπτει με την ένδειξη της ταχύτητας της μηχανής (125). 

6. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Κατασκευάζοντας τον αριθμό φωτογραφίας 
7. Ανάμεσα στο εικονίδιο Digital Movie “Ταχύτητα κλείστρου” και στο εικονίδιο 

map “fstops” εισάγετε ένα εικονίδιο Digital Movie με το όνομα: Αριθμός 
Φωτογραφιών. 

8. Εισάγετε την ακολουθία εικόνων “Fram00??.bmp” κάνοντας τις αντίστοιχες με 
προηγούμενα ρυθμίσεις. 

9. Μετακινείστε το πλαίσιο της εικόνας που μόλις τοποθετήσατε, έτσι ώστε να 
συμπίπτει με την ένδειξη του αριθμού φωτογραφίας της μηχανής (1). 

10. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Κατασκευάζοντας την προώθηση του φιλμ 
11. Εισάγετε, αμέσως μετά, ένα εικονίδιο decision. Ονομάστε το Προώθηση φιλμ. 

Ρυθμίστε το στην επιλογή Repeat “Until All Paths Used”. 
12. Εισάγετε δεξιά του ένα εικονίδιο display με το όνομα Θέση 2. 
13. Κάντε διπλό κλικ στο είδος σύνδεσης και αλλάξτε τον τρόπο διαγραφής σε 

“Upon Exit”. 
14. Κάντε shift κλικ στο display “Θέση 2”. Μ’ αυτόν τον τρόπο θα μείνουν στην 

οθόνη οι εικόνες που εμφανίζονται αυτή τη στιγμή, ενώ θα ανοίξει το 
συγκεκριμένο display. 

15. Εισάγετε την εικόνα “Lever2.bmp” με τρόπο ένθεσης “Matted”. Τοποθετείστε την 
πάνω από το μοχλό όπλισης. 

16. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
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17. Εισάγετε ένα επιπλέον εικονίδιο display με το όνομα Θέση 3. στο οποίο να 
εισάγετε και να προσαρμόσετε την εικόνα “Lever3.bmp”. 

18. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Ενημερώνοντας τον αριθμό φωτογραφίας 
19. Βάλτε στο τέλος του decision ένα εικονίδιο Calculation και ονομάστε το: Αύξηση 

Frame. Ανοίξτε το και γράψτε τον κώδικα frame := frame + 1. 
20. Τελειώνοντας πατήστε  Enter με το πλήκτρο Enter του αριθμητικού 

πληκτρολογίου. Το AuthorWare θα πάει να αποθηκεύσει (χωρίς να σας 
ρωτήσει) το περιεχόμενο του παράθυρου υπολογισμών και θα εξετάσει την 
ορθογραφία των μεταβλητών που έχετε πληκτρολογήσει. Μιας και τη 
συγκεκριμένη μεταβλητή δεν την έχει στη λίστα του θα σας ζητήσει να την 
ορίσετε. 

21. Δώστε σαν αρχική τιμή την τιμή 1 και δώστε την περιγραφή Περιέχει τον αριθμό 
της τρέχουσας φωτογραφίας ώστε να θυμάστε όποτε ξαναδουλέψετε με την 
εφαρμογή τι είναι η κάθε μεταβλητή που έχετε ορίσει. 

22. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ.  
23. Κάντε την εισαγωγή ενός εικονιδίου ήχου (Sound) και ονομάστε το: Ήχος 

οπλίσματος. Εισάγετε τον ήχο “Forward.wav”. 
24. Ρυθμίστε το concurrency στην επιλογή “Concurrent” ώστε η εφαρμογή να 

προχωράει όσο θα ακούγεται ο ήχος. 
25. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
26. Επιλέξτε τα εικονίδια ήχου και επιλογής με τα απ’ αυτό εξαρτώμενα. 

Ομαδοποιήστε τα και ονομάστε το εικονίδιο map που θα δημιουργηθεί Όπλισμα.   
27. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Αποθηκεύστε. 
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Μάθημα 8ο. 

Ενεργοποιώντας τον αριθμό φωτογραφίας 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Εισάγετε ένα εικονίδιο interaction και ονομάστε το: Έλεγχος μηχανής. 
3. Σύρτε το εικονίδιο map «Όπλισμα» στα δεξιά του εικονιδίου interaction «Έλεγχος 

μηχανής» που μόλις εισάγατε. 
4. Επιλέξτε “Hot Spot” στο είδος ανάδρασης, μόλις το AuthorWare σας ρωτήσει. 
5. Κάντε διπλό κλικ στο σημείο σύνδεσης του εικονιδίου interaction «Έλεγχος 

μηχανής» με το εικονίδιο map «Όπλισμα». Στις ιδιότητες σύνδεσης βρείτε τον 
τρόπο διαγραφής και επιλέξτε “On Exit”. 

6. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
7. Κάντε shift + διπλό κλικ στο εικονίδιο interaction «Έλεγχος μηχανής». 
8. Μετακινήστε το σημείο ελέγχου «Όπλισμα» πάνω από τον μοχλό που 

χρησιμοποιούμε για να οπλίσουμε τη μηχανή (να προωθήσουμε το φιλμ ώστε 
να είμαστε έτοιμοι να τραβήξουμε την επόμενή μας φωτογραφία). 

9. Προσαρμόστε το μέγεθος της περιοχής ανάδρασης. Προσέξτε να μην καλύπτει 
το κουμπί του κλείστρου (κόκκινο), το καρέ που δείχνει τον τρέχοντα αριθμό 
φωτογραφίας ούτε και τα βελάκια για την αλλαγή ταχύτητας (πράσινο). 

10. Κλείστε το toolbox. 
11. Κάντε διπλό κλικ στο εικονίδιο digital movie «Αριθμός φωτογραφιών». 
12. Στο πλαίσιο διαλόγου των ιδιοτήτων του που θα εμφανιστεί ρυθμίστε σαν εικόνα 

έναρξης (Start Frame) να είναι η FilmCtr και σαν εικόνα τέλους (End Frame) η 
NewFilmCtr. 

13. Ρυθμίστε επίσης να παίζονται 4 frames το δευτερόλεπτο (Rate) και πιέστε “OK”. 
14. Επειδή δεν αναγνωρίζει τα ονόματα που μόλις δώσατε, θα τα θεωρήσει σαν 

μεταβλητές οριζόμενες από το χρήστη κι έτσι θα σας ζητήσει πληροφορίες γι’ 
αυτές. Δώστε 1 σαν initial value και στις δύο και δώστε την περιγραφή Περιέχει 
τον αριθμό του καρέ του φιλμ (από το movie). για την FilmCtr και την περιγραφή 
Περιέχει τον αριθμό του καρέ του φιλμ (από το movie). μετά την προώθηση του 
φιλμ. για την NewFilmCtr. Πατάτε “OK” κάθε φορά που τελειώνετε με μια 
μεταβλητή. 

15. Κάντε διπλό κλικ στο εικονίδιο map «Όπλισμα» για να ανοίξει. Κάντε διπλό κλικ 
στο εικονίδιο calculation «Αύξηση Frame» ώστε να επεξεργαστείτε το 
περιεχόμενο των υπολογισμών που πρέπει να γίνονται για να εμφανίζεται ο 
σωστός αριθμός του καρέ που τραβάμε. 

16. Αντικαταστήστε το περιεχόμενο με το:  
Οι εικόνες είναι οι αριθμοί από το 1 μέχρι 
το 20 καθώς επίσης και τα ενδιάμεσά 
τους ώστε να δίνεται μια ρεαλιστική 
αίσθηση κίνησής τους. Μ’ αυτόν τον 
τρόπο τώρα εξασφαλίζουμε πως κάθε φορά θα φαίνεται το επόμενο ολόκληρο 
νούμερο. 

FilmCtr := NewFilmCtr 
frame := frame + 1 
NewFilmCtr := (frame*2) - 1 
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17. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Πατήστε μερικές φορές πάνω στο μοχλό οπλίσματος και δείτε τον αριθμό του 
καρέ να ανεβαίνει κατά ένα κάθε φορά.  

18. Κλείστε το εικονίδιο map «Όπλισμα». Αποθηκεύστε. 

Ενεργοποιώντας τη ρύθμιση διαφράγματος 
19. Εισάγετε ένα εικονίδιο calculation δεξιά από το εικονίδιο map «Όπλισμα» και 

ονομάστε το: <-. Κάντε διπλό κλικ στο σημείο σύνδεσης του εικονιδίου 
interaction «Έλεγχος μηχανής» με το εικονίδιο calculation «<-». Επιλέξτε να 
εμφανίζεται σαν πλήκτρο (Button). 

20. Προσθέστε στα δεξιά του ένα ακόμα εικονίδιο calculation και ονομάστε το: ->. 
21. Αλλάξτε την έξοδο των δυο τελευταίων εικονιδίων calculation ώστε να 

συνεχίζονται οι εργασίες από εκεί που σταμάτησαν για τους υπολογισμούς. Για 
να γίνει αυτό κάντε Control κλικ δυο φορές στο κάτω μέρος του κάθε εικονιδίου 
(στην έξοδό τους). 

22. Σύρτε το εικονίδιο map «fstops» στα δεξιά του εικονιδίου calculation«->». 
23. Ανοίξτε το εικονίδιο calculation «<-». Γράψτε: fstop := fstop - 1. Πατήστε το δεξί 

Enter (στην αριθμοπινακίδα) ώστε να αποθηκευτεί το περιεχόμενο και να κλείσει 
το πλαίσιο εισαγωγής υπολογισμών. 

24. Επειδή το fstop δεν είναι γνωστό, θα σας ζητήσει πληροφορίες για τη 
μεταβλητή. Δώστε 3 σαν initial value και δώστε την περιγραφή Περιέχει τον 
αριθμό που συνδέεται με το τρέχον fstop. (1 =f2.8, 2=f4, 3=f5.6, 4 = f8, 5=f11). 

25. Ανοίξτε το εικονίδιο calculation «->». Γράψτε: fstop := fstop + 1. Κλείστε το. 
Τώρα δεν ρωτάει τίποτα μιας και οι μεταβλητές είναι ήδη ορισμένες. 

26. Κάντε διπλό κλικ στο σημείο σύνδεσης του εικονιδίου interaction «Έλεγχος 
μηχανής» με το εικονίδιο map «fstops». Επιλέξτε η σύνδεση να είναι τύπου 
Conditional. Μετονομάστε το σε: fstop <> previous fstop. Το previous fstop είναι 
νέα μεταβλητή. Δώστε 3 σαν initial value και την περιγραφή: Περιέχει τον αριθμό 
που συνδέεται με το τρέχον fstop, πριν αλλαχτεί από το χρήστη.. 

27. Αλλάξτε το branch σε “Try again“. 
28. Κάντε shift κλικ στο εικονίδιο interaction «Έλεγχος μηχανής». 
29. Μετακινήστε τα πλήκτρα «<-» και «->» αριστερά και δεξιά από το διάφραγμα 

για να μας βοηθήσουν αργότερα να ρυθμίσουμε κατάλληλα το διάφραγμα για 
κάθε φωτογραφία. 

30. Κάντε διπλό κλικ στο εικονίδιο map «fstops <> previous fstop». Κάντε διπλό 
κλικ στο εικονίδιο Decision «Διάφραγμα». Επιλέξτε να μην επαναλαμβάνετε το 
κάθε display (Don’t Repeat) και να οδηγείται σε προκαθορισμένο display  
σύμφωνα με τους υπολογισμούς (To Calculated Path). Δώστε τον τύπο previous 
fstop := fstop για οδηγό. (όλες οι μεταβλητές είναι γνωστές στο AuthorWare). 

31. Κλείστε το εικονίδιο map «fstops <> previous fstop». 
32. Για να μην εμφανίζονται τα πλήκτρα αλλαγής διαφράγματος όταν το διάφραγμα 

έχει φτάσει στο τέρμα επιλέξτε “Hide When Inactive” και ρυθμίστε το Active if  σε 
fstop > 1 για το πλήκτρο «<-» και fstop < 5 για το πλήκτρο «->». 

33. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 
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Μάθημα 9ο. 

Ενεργοποιώντας τη ρύθμιση ταχύτητας 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Εισάγετε ένα εικονίδιο calculation δεξιά από το εικονίδιο map «fstop <> 

previous fstop». Κάντε διπλό κλικ στο σημείο σύνδεσης του εικονιδίου 
interaction «Έλεγχος μηχανής» με το εικονίδιο calculation που μόλις εισάγατε. 
Επιλέξτε να εμφανίζεται σαν θερμό σημείο (Hot Spot). Ονομάστε το: Πιο 
γρήγορα. 

3. Ήδη τα εικονίδια που έχουν προστεθεί δίπλα στο εικονίδιο interaction «Έλεγχος 
μηχανής» έχουν πληθύνει. Βλέπετε ότι το AuthorWare μας εμφανίζει μόνο 5 
εικονίδια και για τα υπόλοιπα υπάρχουν αποσιωπητικά. Συγχρόνως στο δεξί 
μέρος η λίστα των εικονιδίων εμφάνισε μια μπάρα κύλισης με την οποία 
μπορούμε διαλέγοντας το όνομα του εικονιδίου που θέλετε να το δείτε στο 
διάγραμμα ροής της εργασίας. 

4. Προσθέστε στα δεξιά του ένα ακόμα εικονίδιο calculation και ονομάστε το: Πιο 
αργά. 

5. Αλλάξτε την έξοδο των δυο τελευταίων εικονιδίων calculation ώστε να 
συνεχίζονται οι εργασίες από εκεί που σταμάτησαν για τους υπολογισμούς. Για 
να γίνει αυτό κάντε Control κλικ δυο φορές στο κάτω μέρος του κάθε εικονιδίου 
(στην έξοδό τους). 

6. Ανοίξτε το εικονίδιο calculation «Πιο γρήγορα». Γράψτε: 
Οι εικόνες ταχύτητας είναι οι αριθμοί 1, 2, 4, 8, 15, 30, 
60, 125, 250, 500, 1000 καθώς επίσης και τα 
ενδιάμεσά τους κι έτσι τώρα εξασφαλίζετε πως κάθε 
φορά θα φαίνεται το επόμενο νούμερο ταχύτητας. 
Πατήστε το δεξί Enter (στην αριθμοπινακίδα) ώστε να αποθηκευτεί το 
περιεχόμενο και να κλείσει το πλαίσιο εισαγωγής υπολογισμών. 

7. Επειδή το start δεν είναι γνωστό, θα σας ζητήσει πληροφορίες για τη 
μεταβλητή. Δώστε 15 σαν initial value και δώστε την περιγραφή Περιέχει τον 
αριθμό του πρώτου πλαισίου του βίντεο για την ταχύτητα. Ορίστε το shutter να 
είναι 8 και σαν Περιέχει τον αριθμό της τρέχουσας ταχύτητας, (αυτό θα εμφανίζει 
την ταχύτητα 125 όταν ξεκινά η εφαρμογή) το _End να είναι 15 και σαν Περιέχει 
τον αριθμό του τελευταίου πλαισίου του βίντεο για την ταχύτητα και το Speed να 
είναι 0 και σαν Περιέχει την ταχύτητα (σε frames ανά sec) που θα παιχτεί η 
κίνηση. 

8. Ανοίξτε το εικονίδιο calculation «Πιο αργά». Γράψτε: 
Κλείστε το. Τώρα δεν ρωτάει τίποτα μιας και οι 
μεταβλητές είναι ήδη ορισμένες. 

9. Μετακινήστε τις περιοχές «Πιο γρήγορα» και «Πιο 
αργά» που μόλις εισάγατε πάνω από τα αντίστοιχα 
σημεία (πράσινα βελάκια) της εικόνας μας ώστε να αλλάζει η ταχύτητα 
αντίστοιχα. 

10. Ανοίξτε το εικονίδιο Digital movie «Ταχύτητα κλείστρου». Βάλτε το να ξεκινάει 
από το Start και να τελειώνει στο _End ώστε να ενεργοποιηθεί η αλλαγή της 
εμφάνισης της ταχύτητας της μηχανής  από τα κλικ του ποντικιού στα 

Start := (shutter*2) - 1 
shutter := shutter - 1 
_End := (shutter*2) - 1 
Speed := - 3 

Start := (shutter*2) - 1 
shutter := shutter + 1 
_End := (shutter*2) - 1 
Speed := 3 
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αντίστοιχα σημεία. Επίσης ζητείστε να παίζεται κάθε frame ώστε να είναι πιο 
εντυπωσιακή η κίνηση. 

11. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Τραβώντας φωτογραφίες 
12. Εισάγετε ένα εικονίδιο map δεξιά από το εικονίδιο map «Όπλισμα» (και πριν τα 

εικονίδια calculation) και ονομάστε το: Τράβηγμα. 
13. Εισάγετε στην περιοχή εργασίας του εικονίδιο map «Τράβηγμα» ένα εικονίδιο 

calculation και ονομάστε το: Υπολογισμός αριθμού καρέ. 
14. Ανοίξτε το εικονίδιο calculation και γράψτε: picture := fstop + shutter - 7. Όταν το 

κλείσετε θα πρέπει να ορίσετε τις μεταβλητή picture στην τιμή 0 (χωρίς να είναι 
απαραίτητο αφού η τιμή υπολογίζεται πριν χρησιμοποιηθεί) και σαν Περιέχει τον 
αριθμό της εικόνας (1 - 7) που θα εμφανιστεί όταν ο χρήστης "τραβήξει τη 
φωτογραφία" ανάλογα με τις ρυθμίσεις για  το διάφραγμα και την ταχύτητα. 

Χρησιμοποιώντας αντικείμενα 
15. Εισάγετε ένα εικονίδιο decision αμέσως μετά και ονομάστε το: Επιλογή 

αρνητικού. 
16. Ανοίξτε την βιβλιοθήκη (Library) του AuthorWare με το όνομα «Photos.a5l» 

(“Files -> Open -> Library”). Οι βιβλιοθήκες χρησιμοποιούνται από τα 
προγράμματα για να μπορούμε να χρησιμοποιούμε κάποια στοιχεία χωρίς να 
τα δημιουργούμε κάθε φορά. Μοιάζουν με τα μοντέλα με μια βασική διαφορά: 
Τα μοντέλα είναι έτοιμα τμήματα προγράμματος που μπορούν να τρέξουν και 
μόνα τους. Οι βιβλιοθήκες περιέχουν στοιχεία που μπορούμε να 
χρησιμοποιήσουμε όποια απ’ αυτά θέλουμε και εμφανίζονται μόνο αφού τα 
εντάξουμε εμείς στο διάγραμμα ροής που κατασκευάζουμε. 

17. Εισάγετε δεξιά του εικονιδίου decision «Επιλογή αρνητικού» το εικονίδια display 
της βιβλιοθήκες με το όνομα +3 stop. Ρυθμίστε να μην διαγράφεται με την 
έξοδο (Don’t Erase). Μια αλυσίδα θα εμφανιστεί στη βιβλιοθήκη αριστερά από 
το εικονίδιο, σημάδι πως το συγκεκριμένο εικονίδιο display έχει χρησιμοποιηθεί 
στην εφαρμογή σας. 

18. Εισάγετε δεξιά του εικονιδίου +3 stop 6 ακόμα εικονίδια της βιβλιοθήκης με το 
όνομα (κατά σειρά) +2 stop, +1 stop, Σωστή έκθεση, -1 stop, -2 stop, -3 stop. 

19. Επιλέξτε τον τύπο του εικονιδίου decision «Επιλογή αρνητικού» να είναι του 
τύπου To Calculated Path ώστε να σας οδηγεί στην εικόνα που θέλετε και αυτή 
βέβαια είναι η picture. 

20. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Πατώντας στο κλείστρο δεν θα διαπιστώσετε καμιά αντίδραση. Αυτό συμβαίνει 
γιατί δεν έχει τοποθετηθεί σωστά το hot spot «Τράβηγμα». 

21. Ανοίξτε το εικονίδιο interaction «Έλεγχος μηχανής» έτσι ώστε να φαίνεται και η 
εικόνα της μηχανής. Βρείτε που είναι το hot spot «Τράβηγμα» και σύρτε το 
πάνω στο κουμπί του κλείστρου (κόκκινο). Προσαρμόστε το μέγεθός του να 
είναι ακριβώς γύρω από το κουμπί χωρίς να επικαλύπτει τον αριθμό του καρέ ή 
το μοχλό οπλίσματος ή τις περιοχές για αλλαγή της ταχύτητας. 

22. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 
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Μάθημα 10ο. 

Λίγο περισσότερος εντυπωσιασμός 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Ανοίξτε το εικονίδιο interaction «Έλεγχος μηχανής» έτσι ώστε να φαίνεται και η 

εικόνα της μηχανής. Γράψτε πάνω αριστερά οδηγίες για το χρήστη: Όπλισε, 
ρύθμισε διάφραγμα και ταχύτητα και τράβα μερικές φωτογραφίες. Προσαρμόστε 
κατάλληλα το πλάτος. 

3. Εισάγετε την εικόνα «Slide2.bmp» και βάλτε την κάτω από τις οδηγίες. 
4. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Τραβήξτε μερικές φωτογραφίες με διαφορετικές ρυθμίσεις διαφράγματος και 
ταχύτητας έτσι ώστε να εμφανιστούν όλα (τα 7 δηλ. συνολικά) αρνητικά που 
έχουμε. Ή αλλιώς, αφού εμφανίσετε και τοποθετήσετε το πρώτο (που στην 
ταχύτητα 125 και το διάφραγμα 5,6 εμφανίζει το καρέ που θεωρείται σαν σωστή 
έκθεση(, κάντε shift + κλικ σε κάθε ένα από τα εικονίδια display του decision 
«Επιλογή αρνητικού» ώστε να εμφανιστούν στην οθόνη σας. Πάρτε το κάθε ένα 
όταν εμφανίζετε και σύρτε το ώστε να περιβάλλεται  από το πλαίσιο slide που 
έχουμε βάλει. 

5. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

6. Ανοίξτε το εικονίδιο map «Τράβηγμα» και στην περιοχή εργασίας που 
εμφανίζεται βάλτε κατ’ αρχάς ένα εικονίδιο Sound ώστε να ακούμε το κλικ της 
μηχανής κατά το πάτημα του κουμπιού. Ονομάστε το: Ήχος click. 

7. Εισάγετε το αρχείο ήχου «click.wav» για να παίζεται από το εικονίδιο ήχου που 
μόλις εισάγατε. 

8. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. Η 
μηχανή για λίγο εξαφανίζεται. Αυτό γίνεται γιατί σταματάει η διαδικασία μέχρι να 
ακουστεί ολόκληρος ο ήχος. κάντε διπλό κλικ στο εικονίδιο sound «Ήχος click» 
και ρυθμίστε το παίξιμό του να είναι “Concurrent”. 

9. Εισάγετε ένα εικονίδιο display αμέσως μετά το εικονίδιο sound «Ήχος click»και 
ονομάστε το: Γράψιμο click. 

10. Εισάγετε το αρχείο «balloon.bmp» για να εμφανίζεται από το εικονίδιο display 
που μόλις εισάγατε. Μετακινήστε την εικόνα στα δεξιά της φωτογραφικής 
μηχανής σας. 

11. Εισάγετε ένα εικονίδιο erase αμέσως μετά και ονομάστε το: Διαγραφή click. 
12. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Πατήστε το κουμπί για να πάρετε μια φωτογραφία. Θα εμφανιστεί το εικονίδιο 
erase για να σας ρωτήσει τι είναι αυτό που θέλετε να διαγράψετε. Πατήστε με το 
ποντίκι σας πάνω στο μπαλονάκι που γράφει click. 

13. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε.  
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Βάζοντας τα πράγματα σε μια σειρά. 
14. Τοποθετήστε ένα εικονίδιο erase ακριβώς δεξιά στο εικονίδιο interaction 

«Έλεγχος μηχανής». Επιλέξτε να είναι τύπου Button και ονομάστε το: 
Επιστροφή στο μενού. 

15. Επιλέξτε το πάτημά του να σας βγάζει από το interaction «Έλεγχος μηχανής». 
16. Τοποθετήστε το πλήκτρο «Επιστροφή στο μενού», που τώρα εμφανίζεται, στο 

κάτω από το πλαίσιο slide που έχετε τοποθετήσει. 
17. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 

Πατήστε στο πλήκτρο «Επιστροφή στο μενού». Θα σας ρωτήσει τι να 
διαγράψει. Πατήστε διαδοχικά πάνω στην εικόνα της μηχανής, στα πλαίσια με 
τους αριθμούς καρέ και ταχύτητας και τέλος στο περιεχόμενο του  εικονιδίου 
interaction «Έλεγχος μηχανής» (δηλ. κάπου στο πλαίσιο slide ή στις οδηγίες). 

18. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Πατήστε στο πλήκτρο «Επιστροφή στο μενού». Επειδή αυτό μένει ακόμα στην 
οθόνη (κάτι, βέβαια, που δεν θέλουμε) επιλέξτε να κρύβεται όταν δεν είναι 
ενεργό. 

19. Επειδή όπως έχει κατασκευαστεί μέχρι τώρα η εφαρμογή, είναι δυνατόν 
κάποιος να οπλίζει συνέχεια χωρίς να τραβάει φωτογραφίες πρέπει να το 
απαγορέψετε. Γι’ αυτό ανοίξτε το εικονίδιο map «Όπλισμα» και σ’ αυτό το 
εικονίδιο calculation «Αύξηση frame». Στο τέλος του κώδικα προσθέστε: 
advanced := TRUE. Στην ερώτηση για τη μεταβλητή δώστε αρχική τιμή 1 και 
περιγραφή: Προχώρησε το φιλμ στο επόμενο καρέ?. 

20. Ανοίξτε το εικονίδιο map «Τράβηγμα» και σ’ αυτό το εικονίδιο calculation 
«Υπολογισμός αριθμού καρέ». και γράψτε: 
(συμπληρώστε) Έτσι ξέρετε α) ότι δεν θα βγει 
εκτός ορίων στις φωτογραφίες μ’ αποτέλεσμα 
να υπάρχει αναντιστοιχία μεταξύ αρνητικού 
που θα εμφανίζεται και συνδυασμού 
ρυθμίσεων ταχύτητας και διαφράγματος και β) 
αν ο χρήστης έχει οπλίσει (χωρίς να 
«τραβήξει») ή όχι (μόλις «πήρε» μια φωτογραφία). 

21. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

picture := fstop + shutter - 7 
Test(picture > 7; picture := 7) 
Test(picture < 1; picture := 1 ) 
advanced := FALSE 
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Μάθημα 11ο. 

Τελικές βελτιώσεις 
1. Ανοίξτε την εφαρμογή σας και επιλέξτε “Control -> Restart from Flag". Δοκιμάστε 

την εφαρμογή μέχρι εδώ. 
2. Βάλτε ένα εικονίδιο display αμέσως μετά το εικονίδιο map «Όπλισμα» και 

ονομάστε το: Έχεις οπλίσει. 
3. Ρυθμίστε το εικονίδιο map «Όπλισμα» ώστε να είναι ενεργό μόνο αν η 

μεταβλητή advanced είναι ψευδής (advanced = FALSE). 
4. Πάρτε το hot spot «Έχεις οπλίσει» που φαίνεται τώρα στην περιοχή του 

εικονιδίου interaction «Έλεγχος μηχανής» και σύρτε το πάνω στο hot spot 
«Όπλισμα» ώστε να συμπέσει ακριβώς. 

5. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε να οπλίσετε. Στο παράθυρο 
του display «Έχεις οπλίσει», σε κατάλληλο σημείο, γράψτε: Έχεις οπλίσει και το 
φιλμ έχει ήδη προχωρήσει. 

6. Πρέπει επίσης να αποτρέψουμε το διπλοτράβηγμα (δηλ. τράβηγμα χωρίς 
όπλισμα). Προς τούτο, βάλτε ένα εικονίδιο display αμέσως μετά το εικονίδιο 
map «Τράβηγμα» και ονομάστε το: Δεν όπλισες.  

7. Επίσης ρυθμίστε το εικονίδιο map ώστε να είναι ενεργό μόνο αν η μεταβλητή 
advanced είναι αληθής (advanced = True ή και απλά advanced η τιμή True, 
σαφώς εννοείται). 

8.  Πάρτε το hot spot «Δεν όπλισες» που φαίνεται τώρα στην περιοχή του 
εικονιδίου interaction «Έλεγχος μηχανής» και σύρτε το πάνω στο hot spot 
«Τράβηγμα» ώστε να συμπέσει ακριβώς. 

9. Επιλέξτε “Control -> Restart from Flag". Προσπαθήστε να πατήστε το κλείστρο 
δυο συνεχόμενες φορές. Στο παράθυρο του display «Δεν όπλισες», σε 
κατάλληλο σημείο, γράψτε: Μην ξεχνάς να οπλίσεις. 

10. Για να μην μένουν τα μηνύματα σφάλματος αφού ο χρήστης έχει κάνει σωστή 
επιλογή ρυθμίστε ώστε τα εικονίδια display «Έχεις οπλίσει» και «Δεν όπλισες», 
να διαγράφονται αφού επέλθει κάποια αλλαγή (After Next Entry). 

11. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
12. Για να μην γυρίζει η ταχύτητα από το 1000 στο 1 και αντιθέτως ρυθμίστε ώστε  

τα hot spot «Πιο γρήγορα» και «Πιο αργά» να είναι ενεργά μόνο αν η ένδειξη 
shutter είναι μικρότερη του 11 και μεγαλύτερη του 1 αντίστοιχα (για τις ακραίες 
τιμές). 

13. Επιλέξτε “Control -> Restart from Flag". Δοκιμάστε την εφαρμογή μέχρι εδώ. 
Αποθηκεύστε. 

Ετοιμάζοντας την εφαρμογή για διανομή 
Όταν φτιάχνετε μια εφαρμογή δεν το κάνετε, συνήθως, ούτε για να περάσετε 

την ώρα σας ούτε για να τη βλέπετε και να την καμαρώνετε μόνο εσείς. Την φτιάχνετε 
για να την δώσετε σε κάποιο τρίτο χρήστη είτε αυτός είναι κάποιος συγγενής ή φίλος 
σας είτε κάποιος πελάτης. Για να γίνει αυτό θα πρέπει πρώτα να την «πακετάρετε». 
Να φτιάξετε δηλ. ένα αρχείο για διανομή τέτοιο που δεν θα απαιτεί  από το χρήστη να 
γνωρίζει τις εντολές του πακέτου συγγραφής (στην περίπτωσή μας του AuthorWare) 
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για να δει την εφαρμογή που φτιάξατε. Επίσης δεν θα είναι υποχρεωμένος να έχει 
την πλήρη (=εμπορική και επί πληρωμή) έκδοση του πακέτου συγγραφής. 

Οι κατασκευαστές των πακέτων αυτών δίνουν συνήθως μαζί είτε μια runtime 
έκδοση (δηλ. που να είναι μόνο για να δείτε το αποτέλεσμα κι όχι για να φτιάξετε) είτε 
ακόμα και τη δυνατότητα για δημιουργία μιας μεταγλωττισμένης εφαρμογής ικανής να 
τρέξει από μόνη της (πράγμα, βέβαια, που σημαίνει μεγαλύτερο μέγεθος αρχείου). 
14. Με ανοιχτό το αρχείο της εφαρμογής, που μόλις ολοκληρώσατε, επιλέξτε “File -

> Package". Στο πλαίσιο διαλόγου που ακολουθεί διαλέξτε αν η εφαρμογή θα 
μπορεί να σταθεί μόνη της ή θα είναι σε συνδυασμό με την αντίστοιχη runtime 
εφαρμογή. Αποφασίστε για πια πλατφόρμα επίσης θα γίνει το «πακετάρισμα». 
Μια εφαρμογή για 16bit περιβάλλον (όπως τα Windows 3.1) μπορεί να τρέξει 
και σε περιβάλλον 32bit, (όπως τα Windows 95/98 ή τα ΝΤ) όμως σίγουρα όχι 
τόσο ικανοποιητικά και χωρίς να εκμεταλλεύεται όλες του τις δυνατότητες. 

15. Αφού τσεκάρετε τα τετραγωνάκια που έχουν να κάνουν με την εσωτερική 
αποθήκευση των βιβλιοθηκών και των εξωτερικών μέσων (εικόνων ήχου κλπ 
που τυχόν έχετε συνδέσει), επιλέξτε το “Save File(s) & Package”. To AuthorWare 
θα σας ετοιμάσει την εφαρμογή όπως του ζητήσατε. 

16. Δοκιμάστε το αρχείο που δημιουργήθηκε. Θα έχει το ίδιο όνομα με αυτό που 
είχατε ανοιχτό τη στιγμή του πακεταρίσματος ή το AuthorWare θα σας ρώτησε 
για όνομα ανάλογα τι επιλέξατε στις επιλογές του πακεταρίσματος. 

17. Δεν πάει καλά? Σας βγάζει μηνύματα λάθους? Μην στεναχωριέστε. Δεν κάνατε 
κάτι λάθος. Είναι ο τρόπος που ετοιμάζει την εφαρμογή το AuthorWare. 
Πακετάρει μαζί την εφαρμογή που ετοιμάσατε και τη μηχανή παρουσίασης αλλά 
λείπουν τα Xtras. Τι είναι αυτά? Μικρές βοηθητικές βιβλιοθήκες του AuthorWare 
για το διάβασμα των εξωτερικών αρχείων και την παρουσίαση τους (ακόμα κι 
αν είναι αποθηκευμένα εσωτερικά). Δημιουργήστε, λοιπόν, ένα υποφάκελο στον 
ίδιο φάκελο με το προς διανομή αρχείο και ονομάστε τον: Xtras. 

18. Ανοίξτε τον φάκελο «C:\Program Files\Macromedia\AuthorWare 5\Xtras» (ή 
όπου έχετε ορίσει κατά την εγκατάσταση του AuthorWare). Επιλέξτε τα 
απαραίτητα αρχεία – συμπληρώματα με την ενδεικνυόμενη επέκταση X16 για 
περιβάλλον 16bit και X32 για περιβάλλον 32bit. Στη συγκεκριμένη περίπτωση 
χρειάζεστε τα: a3sread, bmpview, Mix32, mixview, Thebyte, viewsvc και 
wavread. Αυτά είναι για την παρουσίαση αρχείων εικόνας και ήχου της μορφής 
που χρησιμοποιήσατε (bmp και wav) καθώς και του (εξωτερικού) εφέ του 
τέλους. (Για περισσότερες πληροφορίες για το ποιο xtras χρειάζεται για κάθε 
περίπτωση στη βοήθεια του AuthorWare). Αντιγράψτε τα (ΠΡΟΣΟΧΗ: να γίνει 
αντιγραφή κι όχι μετακίνηση) στο φάκελο Xtras που δημιουργήσατε. 

19. Δοκιμάστε την εφαρμογή. 
Τώρα όλα πρέπει να πηγαίνουν καλά. Συγχαρητήρια. Καταφέρατε να 

δημιουργήσετε την πρώτη σας εφαρμογή στο AuthorWare. Τώρα μπορείτε να 
δουλέψετε πάνω στις δικές σας ιδέες και θέματα. 

Καλή επιτυχία. 
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